import re
regex = re.compile(r"((?![^<]*?>)\b[\w\h]{7,})")
test_str = ("<html>\n"
" <tabel tags=\"gohere'>\n"
" <tr>\n"
" <td>detects strings</td>\n"
" <td>\n"
" of a\n"
" length\n"
" </td>\n"
" </tr>\n"
" <tr>\n"
" <td>\n"
" and <b> ignores HTML </b>\n"
" <br />\n"
" formating\n"
" </td>\n"
" <td> this checks for string atleast 7 char in length <td>\n"
" </tr>\n"
" </table>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")