re = /((?![^<]*?>)\b[\w\h]{7,})/
str = '<html>
<tabel tags="gohere\'>
<tr>
<td>detects strings</td>
<td>
of a
length
</td>
</tr>
<tr>
<td>
and <b> ignores HTML </b>
<br />
formating
</td>
<td> this checks for string atleast 7 char in length <td>
</tr>
</table>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end