$re = '/((?![^<]*?>)\b[\w\h]{7,})/';
$str = '<html>
<tabel tags="gohere\'>
<tr>
<td>detects strings</td>
<td>
of a
length
</td>
</tr>
<tr>
<td>
and <b> ignores HTML </b>
<br />
formating
</td>
<td> this checks for string atleast 7 char in length <td>
</tr>
</table>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);