using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?![^<]*?>)\b[\w\h]{7,})";
string input = @"<html>
<tabel tags=""gohere'>
<tr>
<td>detects strings</td>
<td>
of a
length
</td>
</tr>
<tr>
<td>
and <b> ignores HTML </b>
<br />
formating
</td>
<td> this checks for string atleast 7 char in length <td>
</tr>
</table>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}