using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--((?!batcache)(?!\[endif\])[\s\S])*?-->";
string input = @"<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
<!--
generated 37 seconds ago
generated in 0.978 seconds
served from batcache in 0.004 seconds
expires in 263 seconds
-->
<!--asdasd asldasldkaslòdk
batcahe
asd
as-->
<!--asdasd asldasldkaslòdk
batcaRO
asd
as-->
<!--asdasd asldasldkaslòdk
batcache
asd
as-->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}