import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--((?!batcache)(?!\\[endif\\])[\\s\\S])*?-->";
final String string = "<!--[if IE 6]>\n"
+ " Special instructions for IE 6 here\n"
+ "<![endif]-->\n\n"
+ "<!--\n"
+ "generated 37 seconds ago\n"
+ "generated in 0.978 seconds\n"
+ "served from batcache in 0.004 seconds\n"
+ "expires in 263 seconds\n"
+ "-->\n\n"
+ "<!--asdasd asldasldkaslòdk\n"
+ " batcahe\n"
+ "asd\n"
+ "as-->\n\n"
+ "<!--asdasd asldasldkaslòdk\n"
+ " batcaRO\n"
+ "asd\n"
+ "as-->\n\n"
+ "<!--asdasd asldasldkaslòdk\n"
+ " batcache\n"
+ "asd\n"
+ "as-->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}