use strict;
my $str = '<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
<!--
generated 37 seconds ago
generated in 0.978 seconds
served from batcache in 0.004 seconds
expires in 263 seconds
-->
<!--asdasd asldasldkaslòdk
batcahe
asd
as-->
<!--asdasd asldasldkaslòdk
batcaRO
asd
as-->
<!--asdasd asldasldkaslòdk
batcache
asd
as-->';
my $regex = qr/<!--((?!batcache)(?!\[endif\])[\s\S])*?-->/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}