$re = '/<!--((?!batcache)(?!\[endif\])[\s\S])*?-->/';
$str = '<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
<!--
generated 37 seconds ago
generated in 0.978 seconds
served from batcache in 0.004 seconds
expires in 263 seconds
-->
<!--asdasd asldasldkaslòdk
batcahe
asd
as-->
<!--asdasd asldasldkaslòdk
batcaRO
asd
as-->
<!--asdasd asldasldkaslòdk
batcache
asd
as-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);