const regex = /<!--((?!batcache)(?!\[endif\])[\s\S])*?-->/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--((?!batcache)(?!\\[endif\\])[\\s\\S])*?-->', 'g')
const str = `<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
<!--
generated 37 seconds ago
generated in 0.978 seconds
served from batcache in 0.004 seconds
expires in 263 seconds
-->
<!--asdasd asldasldkaslòdk
batcahe
asd
as-->
<!--asdasd asldasldkaslòdk
batcaRO
asd
as-->
<!--asdasd asldasldkaslòdk
batcache
asd
as-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}