import re
regex = re.compile(r"<!--((?!batcache)(?!\[endif\])[\s\S])*?-->")
test_str = ("<!--[if IE 6]>\n"
" Special instructions for IE 6 here\n"
"<![endif]-->\n\n"
"<!--\n"
"generated 37 seconds ago\n"
"generated in 0.978 seconds\n"
"served from batcache in 0.004 seconds\n"
"expires in 263 seconds\n"
"-->\n\n"
"<!--asdasd asldasldkaslòdk\n"
" batcahe\n"
"asd\n"
"as-->\n\n"
"<!--asdasd asldasldkaslòdk\n"
" batcaRO\n"
"asd\n"
"as-->\n\n"
"<!--asdasd asldasldkaslòdk\n"
" batcache\n"
"asd\n"
"as-->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")