# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\A|\s)#(\w+)/\1#<a href="http:\/\/search.twitter.com\/search?q=%23\2">\2<\/a>/g;t' <<< "This is #hashtag finder that looks for all the #tags in a tweet object!"