#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\A|\s)#(\w+)"
Local $sString = "This is #hashtag finder that looks for all the #tags in a tweet object!"
Local $sSubst = "\1#<a href="http://search.twitter.com/search?q=%23\2">\2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)