const regex = new RegExp('(\\A|\\s)#(\\w+)', 'g')
const str = `This is #hashtag finder that looks for all the #tags in a tweet object!`;
const subst = `\1#<a href="http://search.twitter.com/search?q=%23\2">\2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);