re = /(\A|\s)#(\w+)/
str = 'This is #hashtag finder that looks for all the #tags in a tweet object!'
subst = '\\1#<a href="http://search.twitter.com/search?q=%23\\2">\\2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result