// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\A|\s)#(\w+)").unwrap();
let string = "This is #hashtag finder that looks for all the #tags in a tweet object!";
let substitution = "\\1#<a href=\"http://search.twitter.com/search?q=%23\\2\">\\2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}