use strict;
my $str = 'This is #hashtag finder that looks for all the #tags in a tweet object!';
my $regex = qr/(\A|\s)#(\w+)/p;
my $subst = '\\1#<a href="http://search.twitter.com/search?q=%23\\2">\\2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";