package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\A|\s)#(\w+)`)
var str = `This is #hashtag finder that looks for all the #tags in a tweet object!`
var substitution = "\1#<a href="http://search.twitter.com/search?q=%23\2">\2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}