const regex = /(?=#include)(?![^{]*})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=#include)(?![^{]*})', 'g')
const str = `#include "weoifhsdf/weoifh/wfoih.txt"
\$tea1(wwoeifhwe)
{
}`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);