use strict;
my $str = '#include "weoifhsdf/weoifh/wfoih.txt"
$tea1(wwoeifhwe)
{
}';
my $regex = qr/(?=#include)(?![^{]*})/p;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";