# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^.+\\/)([^\.]+)\.([^\.]+)/$1$2XXXXXXXXXXXXL.$3/;t' <<< "upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg"