$re = '/(^.+\/)([^\.]+)\.([^\.]+)/';
$str = 'upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg';
$subst = "$1$2XXXXXXXXXXXXL.$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;