using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.+\/)([^\.]+)\.([^\.]+)";
string substitution = @"$1$2XXXXXXXXXXXXL.$3";
string input = @"upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}