// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^.+\/)([^\.]+)\.([^\.]+)").unwrap();
let string = "upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg";
let substitution = "$1$2XXXXXXXXXXXXL.$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}