#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^.+\/)([^\.]+)\.([^\.]+)"
Local $sString = "upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg"
Local $sSubst = "$1$2XXXXXXXXXXXXL.$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)