import Foundation
let pattern = #"(^.+\/)([^\.]+)\.([^\.]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2XXXXXXXXXXXXL.$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}