package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\"url\":\ \")(.*)(\")`)
var str = `"id": 1,
"owner_id": 1,
"artist": "foo",
"title": "bar",
"duration": 1,
"date": 1,
"url": "http://vk... .flac",
"lyrics_id": 1,
"genre_id": 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}