import Foundation
let pattern = #"(\"url\":\ \")(.*)(\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"id": 1,
"owner_id": 1,
"artist": "foo",
"title": "bar",
"duration": 1,
"date": 1,
"url": "http://vk... .flac",
"lyrics_id": 1,
"genre_id": 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)