$re = '/(\"url\":\ \")(.*)(\")/';
$str = '"id": 1,
"owner_id": 1,
"artist": "foo",
"title": "bar",
"duration": 1,
"date": 1,
"url": "http://vk... .flac",
"lyrics_id": 1,
"genre_id": 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);