import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\"url\\\":\\ \\\")(.*)(\\\")";
final String string = "\"id\": 1,\n"
+ "\"owner_id\": 1,\n"
+ "\"artist\": \"foo\",\n"
+ "\"title\": \"bar\",\n"
+ "\"duration\": 1,\n"
+ "\"date\": 1,\n"
+ "\"url\": \"http://vk... .flac\",\n"
+ "\"lyrics_id\": 1,\n"
+ "\"genre_id\": 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}