re = /(\"url\":\ \")(.*)(\")/
str = '"id": 1,
"owner_id": 1,
"artist": "foo",
"title": "bar",
"duration": 1,
"date": 1,
"url": "http://vk... .flac",
"lyrics_id": 1,
"genre_id": 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end