import re
regex = re.compile(r"(\"url\":\ \")(.*)(\")")
test_str = ("\"id\": 1,\n"
"\"owner_id\": 1,\n"
"\"artist\": \"foo\",\n"
"\"title\": \"bar\",\n"
"\"duration\": 1,\n"
"\"date\": 1,\n"
"\"url\": \"http://vk... .flac\",\n"
"\"lyrics_id\": 1,\n"
"\"genre_id\": 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")