// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\"url\":\ \")(.*)(\")"#).unwrap();
let string = "\"id\": 1,
\"owner_id\": 1,
\"artist\": \"foo\",
\"title\": \"bar\",
\"duration\": 1,
\"date\": 1,
\"url\": \"http://vk... .flac\",
\"lyrics_id\": 1,
\"genre_id\": 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}