#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)" & @CRLF & _
" (?P<elt>" & @CRLF & _
" [^,()]*+" & @CRLF & _
" (?:" & @CRLF & _
" \( (?&elt) (?: , (?&elt) )* \)" & @CRLF & _
" [^,()]*" & @CRLF & _
" )*+" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" FOO\( \s*" & @CRLF & _
" (?P<elt1> (?&elt) )" & @CRLF & _
" , \s*" & @CRLF & _
" (?P<elt2> (?&elt) )" & @CRLF & _
" , \s*" & @CRLF & _
" (?P<elt3> (?&elt) )" & @CRLF & _
" \)"
Local $sString = "FOO( something, BOO(tmp, temp), something else)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")