import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?P<elt>\n"
+ " [^,()]*+\n"
+ " (?:\n"
+ " \\( (?&elt) (?: , (?&elt) )* \\)\n"
+ " [^,()]*\n"
+ " )*+\n"
+ " )\n"
+ " )\n"
+ " \n"
+ " FOO\\( \\s*\n"
+ " (?P<elt1> (?&elt) )\n"
+ " , \\s*\n"
+ " (?P<elt2> (?&elt) )\n"
+ " , \\s*\n"
+ " (?P<elt3> (?&elt) )\n"
+ " \\)";
final String string = "FOO( something, BOO(tmp, temp), something else)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}