re = /(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)/x
str = 'FOO( something, BOO(tmp, temp), something else)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end