$re = '/(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)/x';
$str = 'FOO( something, BOO(tmp, temp), something else)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);