using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)";
string input = @"FOO( something, BOO(tmp, temp), something else)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}