import Foundation
let pattern = #"""
(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"FOO( something, BOO(tmp, temp), something else)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)