#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*(?:.*?\/){3,})(.*)\/$"
Local $sString = "/foo/bar/baz/" & @CRLF & _
"/foo/bar/" & @CRLF & _
"/foo/bar" & @CRLF & _
"/foo/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)