$re = '/^(?=.*(?:.*?\/){3,})(.*)\/$/m';
$str = '/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;