const regex = /^(?=.*(?:.*?\/){3,})(.*)\/$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(?:.*?\\\/){3,})(.*)\\\/$', 'gm')
const str = `/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);