using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*(?:.*?\/){3,})(.*)\/$";
string substitution = @"\1";
string input = @"/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}