import re
regex = re.compile(r"^(?=.*(?:.*?\/){3,})(.*)\/$", flags=re.MULTILINE)
test_str = ("/foo/bar/baz/\n"
"/foo/bar/\n"
"/foo/bar\n"
"/foo/")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)