re = /^(?=.*(?:.*?\/){3,})(.*)\/$/m
str = '/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result