using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?!(499|495))[\d]{3}\)\s[\d]{3}[\s\d]*)";
string input = @"(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43
(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}