# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\((?!(499|495))[\d]{3}\)\s[\d]{3}[\s\d]*)"
test_str = ("(908) 061 41 18\n"
"(499) 239 22 17\n"
"(926) 135 16 04\n"
"(905) 036 25 24\n"
"(495) 131 50 43\n"
"(908) 061 41 18\n"
"(499) 239 22 17\n"
"(926) 135 16 04\n"
"(905) 036 25 24\n"
"(495) 131 50 43")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.