import Foundation
let pattern = #"(\((?!(499|495))[\d]{3}\)\s[\d]{3}[\s\d]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43
(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)