use strict;
my $str = '(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43
(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43';
my $regex = qr/(\((?!(499|495))[\d]{3}\)\s[\d]{3}[\s\d]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}