import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?!(499|495))[\\d]{3}\\)\\s[\\d]{3}[\\s\\d]*)";
final String string = "(908) 061 41 18\n"
+ "(499) 239 22 17\n"
+ "(926) 135 16 04\n"
+ "(905) 036 25 24\n"
+ "(495) 131 50 43\n"
+ "(908) 061 41 18\n"
+ "(499) 239 22 17\n"
+ "(926) 135 16 04\n"
+ "(905) 036 25 24\n"
+ "(495) 131 50 43";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}