const regex = /(\((?!(499|495))[\d]{3}\)\s[\d]{3}[\s\d]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\((?!(499|495))[\\d]{3}\\)\\s[\\d]{3}[\\s\\d]*)', 'g')
const str = `(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43
(908) 061 41 18
(499) 239 22 17
(926) 135 16 04
(905) 036 25 24
(495) 131 50 43`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}